Great tool - minor issue with reading custom entity create permission on custom security roles

May 10, 2016 at 3:40 AM
I like this tool very much, its so close to being perfect. Just having an issue with the Create permission not being reported correctly for custom entities. It mostly always says NONE even though permissions are definitely assigned. I've only exported these details for custom security roles I've created. Using CRM 2015 RTM on premise.

I can email additional details samples etc if you want or need to help debug the issue, just let me know. For now I'm having to update manually after export which kind of defeats the purpose a little. Oooo, so close.
May 10, 2016 at 6:18 AM
Hi

Thanks for reporting. Would appreciate your help in fixing this.

Could you please let me know, if it happens for all the entities or just a few? If just a few, can you provide more details about the entity.

Regards,
John
May 10, 2016 at 2:06 PM
I can send you a spreadsheet tomorrow with the output from your tool with the screen capture of each custom security role definition as well, trusting that will help.

Sent from my Windows Phone

May 10, 2016 at 3:17 PM
Hi,

I have fixed this issue in the latest release. Please let me know if you still face any issues.

Thanks again for reporting.


Regards,
Johninfant
May 11, 2016 at 8:52 AM
Brilliant thanks Johninfant, it's working perfectly now. Truly a great piece of work and an invaluable tool for any serious CRM Developer and/or Functional Consultant out there. Well done and thanks for the immediate response. Let me know where I can donate.... Cheers
May 12, 2016 at 4:45 AM
Thanks for the appreciation.

It's all I need :D